現場(環境): Cisco 3560 、Cisco 2960
原因:
因為有特殊的需求需要變更公司內的網路設備設定。
Vlan 11 → IT部門
Vlan 20 → 專案部門
今天要求Vlan 11 的工程師A 要到專案部門駐點一個月。
但因為工程師A在IT部門時的IP位址有申請多個伺服器的連線權限。
如果調過去專案部門的話,
那工程師A就得為了這個月重新申請連線權限。
(很麻煩,但這是正確的作法)
為了省去工程師A申請上的麻煩,
我們請網路工程師幫他進行網路設備上的異動
讓他可以使用原本的IP在專案部門工作。
下圖為預計執行示意圖
處理方式:
1. 前置作業 (檢查設定)
我們先到Switch 3560 上面看一下目前網路設備的狀況。
(1) show running
3560#show running
interface FastEthernet0/11 description IT-department switchport access vlan 11 switchport mode access ! |
interface FastEthernet0/20 description Project-department switchport access vlan 20 switchport mode access ! |
interface FastEthernet0/21 description nouse ! |
interface Vlan11 ip address 10.10.11.0 255.255.255.0 ! |
interface Vlan20 ip address 10.10.20.0 255.255.255.0 ! |
2960#show running
interface GigabitEthernet0/1 switchport access vlan 20 switchport mode access ! |
interface GigabitEthernet0/2 description nouse ! |
interface Vlan20 ip address 10.10.10.20 255.255.255.0 ! |
依照這兩台運作中的設定檔我們可以知道現在架構的情形。
(2) show interface trunk
確定一下兩台設備上的trunk狀況。
(正常來說現在兩個應該都會是空白)
3560#show interface trunk
2960#show interface trunk
(3)show vlan
檢查一下兩台設備上的VLAN狀況。
3560#show vlan
(每個port都有對應的vlan)
VLAN |
Name |
Status |
Ports |
11 |
IT-department |
active |
Fa0/11 |
20 |
Project-department |
active |
Fa0/20 |
2960#show vlan
(整台switch都屬於vlan 20)
VLAN |
Name |
Status |
Ports |
20 |
Project-department |
active |
Fa0/1, Fa0/2, ..., Gi0/1, Gi0/2 |
(4) show ip interface brief
檢查設備上的vlan 及 port 的啟用狀況
3560#show ip interface brief
(vlan & port 都正常使用中)
Interface |
IP-Address |
OK? |
Method |
Status |
Protocol |
Vlan11 |
10.10.11.254 |
YES |
manual |
up |
up |
Vlan20 |
10.10.20.254 |
YES |
manual |
up |
up |
FastEthernet0/11 |
unassigned |
YES |
unset |
up |
up |
FastEthernet0/20 |
unassigned |
YES |
unset |
up |
up |
2960#show ip interface brief
(vlan & port 都正常使用中)
Interface |
IP-Address |
OK? |
Method |
Status |
Protocol |
Vlan20 |
10.10.20.253 |
YES |
manual |
up |
up |
GigabitEthernet0/1 |
unassigned |
YES |
unset |
up |
up |
接著我們來準備做相關的設定
2. 設備設定
# 將以 Fa 縮寫稱呼FastEthernet
# 將以 Gi 縮寫稱呼GigabitEthernet
設定trunk時,
會建議採取目前沒有用到的port來做測試,
以避免到時候你切換失敗,你沒有得回上一步。
我們先到Cisco 3560上,針對Fa 0/21 做設定。
因為他先前沒有設定在任何vlan,
所以不用取消掉mode access & access vlan 問題。
如果有需求,先進行下面指令。
[x]表示為該vlan number
(config-if)#no switchport mode access
(config-if)#no switchport access vlan [x]
開始設定trunk
3560> enable
3560#config terminal
3560(config)#interface fa 0/21
3560(config-if)#description trunk_11and20
3560(config-if)#switchport mode trunk
3560(config-if)#switchport trunk encapsulation dot1q
3560(config-if)#switchport trunk native vlan 1
3560(config-if)#switchport trunk allowed 1,11,20
3560(config-if)#channel-group 1 mode on
3560(config-if)#end
3560#copy running-config startup-config
2960> enable
2960#config terminal
2960(config)#interface gi 0/2
2960(config-if)#description trunk_11and20
2960(config-if)#switchport mode trunk
2960(config-if)#switchport trunk native vlan 1
2960(config-if)#switchport trunk allowed 1,11,20
2960(config-if)#channel-group 1 mode on
2960(config-if)#exnd
2960#copy running-config startup-config
基本上兩邊這樣就都設定好了,
再來就是將實體線路移轉。
Cisco3560(fa0/20) → Cisco3560(fa0/21)
Cisco2960(gi0/1) → Cisco2960(gi0/2)
因為工程師A只是一個月的暫派,
所以我們不要把之前port上的設定拿掉。
再你設定完還沒有正式接線前,
#show interface trunk 都不會顯示任何東西。
現在就把線接過去測試。
3.檢查
(1) show running
3560#show running
interface FastEthernet0/11 description IT-department switchport access vlan 11 switchport mode access ! |
interface FastEthernet0/20 description Project-department switchport access vlan 20 switchport mode access ! |
interface FastEthernet0/21 description trunk_11and20 switchport trunk encapsulation dot1q switchport trunk allowed vlan 1,11,20 switchport mode trunk channel-group 1 mode on ! |
interface Vlan11 ip address 10.10.11.0 255.255.255.0 ! |
interface Vlan20 ip address 10.10.20.0 255.255.255.0 ! |
2960#show running
interface GigabitEthernet0/1 switchport access vlan 20 switchport mode access ! |
interface GigabitEthernet0/2 description trunk_11and20 switchport trunk allowed vlan 1,11,20 switchport mode trunk channel-group 1 mode on ! |
interface Vlan20 ip address 10.10.10.20 255.255.255.0 ! |
(2) show interface trunk
確定一下兩台設備上的trunk狀況。
Port |
Mode |
Encapsulation Status |
Native |
vlan |
Fa0/21 |
on |
802.1q |
trunking |
1 |
Port |
Vlans allowed on trunk |
Fa0/21 |
1,11,20 |
2960#show interface trunk
Port |
Mode |
Encapsulation Status |
Native |
vlan |
Po1 |
on |
802.1q |
trunking |
1 |
Port |
Vlans allowed on trunk |
Po1 |
1,11,20 |
(3)show vlan
檢查2960上的比較明顯。
我們可以看到Gi 0/2 已經消失。
(因為trunk 不屬於任何vlan)
VLAN |
Name |
Status |
Ports |
20 |
Project-department |
active |
Fa0/1, Fa0/2, ..., Gi0/1 |
(4) show ip interface brief
檢查一下設定上去port是不是都有啟用就好。
(5) ping [vlan ip address]
設定完trunk後,
我們應該還要可以正常的連線到2960上的vlan IP位址。
3560#ping 10.10.20.253
(!)驚嘆號表示連線成功。
(.)表示連線失敗。
=!===========================
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.20.253, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms
=!===========================
設定到這邊trunk就設定完了。
再來我們只要在Cisco 2960 上設定vlan11,
並將一個沒在用的port 指定到vlan 11 ,
這樣工程師A就可以在專案部門用他原本使用的IP工作了。
備註:
在Cisco 2960上設定要給工程師A用的port。
(1) 設定vlan
2960(config)#vlan 11
2960(config-vlan)#no shutdown
2960(config)#interface vlan 11
2960(config-if)#description IT-department
2960(config-if)#ip address 10.10.11.253 255.255.255.0
2960(config-if)#no shutdown
2960(config-if)#exit
(2) 將port 指定到vlan 11
2960(config)#interface fa 0/24
2960(config-if)#switchport mode access
2960(config-if)#switchport access vlan 11
2960(config-if)#no shutdown
2960(config-if)#end
2960#copy running-confg startup-config
到這邊就算設定完成。
當然要將哪個port轉到vlan11,
要依工程師A到該部門駐點的座位而定。
(本篇完)
留言列表